Linking a Heading [[/ inside a note crashes

Testing version:

What were you doing:
When I want link to a section/heading inside the same note, without copying the link before, by typing [[/ Bear crashes.

What feature did you use:
link to Heading

What happened:
Complete Crash of Bear

What did you expect to happen:
I excpect to See a list of the Headings of the Document. Select one and have the link inside my note.


No problem here. Everything works fine

Did you copy the link before?
When I copy the link with right click on the heading and then typing manually everythings works fine.
But without copying before, it crashes.

I tried further…

it crashes completely, when there is no heading in the note.

so when you have a note without Headings inside and type [[/ as soon as you hit the / bear crashes.

I even tried without headings but nevertheless everything works as expected. Something weird must be going on at your side

tried it on my M1 MacBook Pro it works as shown in your video.

doing the same on my M2 MacBook Air… crash!

Hi and thanks for reporting this issue. I struggle to simulate this issue, any chance the crash happened on a specific note(s)?

Hi Trix,
No… it happens in clean new notes as well as in others.

I‘ll try to capture ist in a Video .

1 Like

this is what I found out:


Got it! thanks, Apparently empty headers cause the crash.