Panda crashes when adding a link

Testing version:
Panda 0.1 (2801)

What were you doing
Adding a link

What feature did you use:
Linking on the Panda keyboard (not the keyboard for tables)

What happened:
Panda crashed, reproducable

What did you expect to happen:
See the added link
After linking in a table I got the expected link

1 Like

Hi there,

May I just ask, is this still occurring for you? If so, what device and system version on the device are you using?

Also, where do you have Panda located?

We’ve received previous reports that when users had unzipped Panda in the downloads folder it caused crashes.

If you move it to Applications it should be working again. Let me know if the issue persists and we’ll investigate further! :slight_smile:


I tried Panda on My MacBook Pro(15 inch 2017), macOS 12.3.1 with Panda 1.0 (2595) located in my Applications Folder.
On this machine no problem: the link was created as expected, and functioned ok.

I also tried to make the same link on my iPhone 13 Pro Max and my iPad Pro 12,9 2021, both with iOS 15.4.1.
I started Panda on both from Testflight, Panda Version 01 (2801).
I created a new document on my iPhone and a new document on my iPad (not on iCloud)

When I tried to make the link from the Panda Keyboard the app crashed directly on iPhone and iPad.
When I made a table first and then created a link in the table, the link was created as expected.

I hope this makes the problem clear,


Peter Terlingen

Hi there Peter,

Thank you for the additional information. I’ll pass it onto the development team to have a look into :slight_smile:

cc - @matteo

I can confirm the same on iOS (iPhone 11, 15.3.1)

Tried adding a link 3x

  1. Heavily formatted page; drawing window, date, ‘folding’ space.

Opened “add link” menu. Link name=‘Google’ URL=“”. App crashed when I clicked “done” on “Edit Link” window.

Reopened app, page was not recovered.

  1. New page, opened “add link” dialog box, added identical information as in the first attempt.

App again crashed when I tapped “done”.

Reopened app, page was not recovered.

  1. Steps to replicate and results were identical to attempt 2

The crash that I described still exists in the new version of Panda :cry:

In build 2952 is the crash gone!

1 Like