App quits when saving files

Testing version:

What were you doing:
I was typing my notes.

What feature did you use:
I tried saving my note.

What happened:
So i tried saving my note and got this pop up that said I had to duplicate file to save (weird?), so I pressed duplicate and the app not only quit but did NOT save my notes so i lost everything. I tried duplicating files but the app just get quitting.

What did you expect to happen:
I expected my file to have been duplicated and saved.

Hello and Welcome,

I’m trying to figure what happened and how to simulate the crash. It’s quite odd the message popped out of the blue, any chance you had another file with the same name but with a different extension in the same folder? If I have understood correctly you get an app crash each time you duplicate a document?

Thanks for reporting this issue.

Hi, very sorry for the late reply. I did not have another file with the same name. I use a MacBook pro 2020 (i don’t know if it’s the new Mac update that’s causing me to have so many issues with Panda but i really really love the app and never gonna stop using it. I just need it to work lol). Also, when I click a Panda file from Desktop and click “Open With Panda”, files do not open :frowning:

Hi James,

“Open With Panda”, files do not open

This is very odd. What kind of file are you trying to open (Markdown, .panda, textbundle, textpack, …)?
Eventually, can you send me the file here or via DM?

I think this was a bug because when I updated my Mac to the latest OS, everything seemed to be resolved. The file was just a note I created from class lectures so let’s say a random note/file with text. I used the previous version of Panda (Panda 1) and sometimes it used to save as .md while other days it got saved as .panda. However with the new Panda 2 and Mac update, I don’t seem to be having these issues anymore. Also thank you for following up and trying to help out. Really appreciate it.