Crashing on import from Evernote

Testing version: Version 2.0 (10670)

What were you doing: Exporting notes from Evernote and importing them into bear

What feature did you use: Import from Evernote

What happened: When trying to import multiple notes from evernote, the app “quits unexpectedly” and did not import the batch of notes. I tried to import a single note from a .enex file and it imported the single note and quit. Then after reopening, whenever I try to open the single note imported from evernote, the app will quit again.

What did you expect to happen: The notes to be imported and able to be accessed.

I’ve also had crashes upon Evernote import, but some imports went successful.

What I’ve found to cause reproducable crashes is having one enex file that contains two notes with the same title. When I export these two notes individually and import them one after another, everything works.

1 Like

Can you please try with the latest build available (10688 macOS or 10699 iOS)?

Just tried it out and it worked. Imported 100 notes successfully

1 Like

It doesn’t crash anymore, but now most (if not all) images are lost. I only get markdown image syntax instead of actual images in Bear e.g.


Just noticed there is no space in between two „images“, maybe an issue with images that don’t have surrounding whitespace in Evernote?

1 Like

same for me :frowning: almost all attachments are gone

Same, all of my attachments are replaced with things like this

We have found where the bug and we’ll ship a fix with the next beta update.

Thanks for reporting this issue.


I’m on 10732 and still seeing some attachments import as:

10732 too – things are looking a lot better, but Bear still has problems importing notes where attachments are included in a table (I know, it’s not the most common case :slight_smile: )