First impressions of Bear 2

Absolutely awesome first impression!!! Bear 2 is very well done. Feels solid/trustworthy, looks beautiful, and search results in images??? OMG!

I thought my very first use of Bear 2 would be one of the best times to provide some honest feedback, so my first Bear 2 note was creating a list of each moment Bear 2 didn’t behave like I expected. Initial import of Bear 1 notes was flawless and 99% of the time, Bear 2 did exactly what I thought it should; here are a few places where I hit a bump:


  • Style bar tooltips: Expected tooltips for style bar buttons to include shortcut keys (e.g., hovering over table icon would show “Table (⌥⌘T)”.
  • Tab to add row: I expected hitting a Tab key in the last cell of a table to add a new row to the end of the table.
  • Section icon on hover: I expected the folding icon to appear when hovering over a section header (rather than having to move the cursor to the section header before seeing it). Consider showing the folding icon when the cursor is anywhere in the section (since ⌘' works on a section no matter where you are in it… nice touch!)
  • Add row cursor behavior: When adding a new row to a table when the cursor is not in the first column, I expect the cursor to move to the first column of the new row rather than moving down to the new row without changing columns.
  • Select text across rows: I expected to be able to hold down shift and arrow up & down through table rows to select text.
  • Link to section: I expected a control-click on a section header to offer a link to the section within the note (e.g., bear2://x-callback-url/open-note?id=0C6290BC-9147-4D8C-A683-96994F6BD9EA#HeaderName that renders like [[Note Title > Section Header]]).
    Update: Bear 2 continues to meet expectations! I just discovered sections do have a “Copy link to here” option. Exactly what I was looking for! Not sure why I didn’t see it. Mea culpa!


  • Special characters: Inserting a special characters (e.g., ) sometimes took two tries. I would press ^⌘space to bring up the special characters dialog, select the character, and return to the editor without the character inserted. Trying again usually worked. — Fixed in Version 2.0 (9780)
  • Link preview in table: Inserting a link with preview inside a table renders incorrectly or crashes Bear 2. — Fixed in Version 2.0 (9780).
  • Footnote in table: Footnotes in a table don’t behave as expected (footnote link doesn’t work).

Great job Bear 2 team! Looking forward to migrating to Bear 2!


Good observations but I’m curious about this one. Why did you have such an expectation? It’s not really a common shortcut or anything.

I suppose Bear 2 raised my expectations. I was testing linking to a note and assumed the new smarter/folding sections would give me the ability to link directly to a section. It’s not really a feature request (though it would be nice)… just something that I thought I would find and didn’t, so added to the list. Why did I think it would be there? Probably the experience of linking to sections in wikis.

@trix180 @matteo

Test copy paste internal links

  1. Copy a header link
  2. Paste with ⌘V gives: [[Welcome to the beta!/Tables]]
  3. Paste From > Plain Text gives: bear2://x-callback-url/open-note?id=6574EDEC-9EE6-464D-B957-576DB7A43161&header=Tables
    so a raw link and not a markdown link!

Would be nice to be able to paste as link as markdown like this:
[Welcome to the beta!/Tables](bear2://x-callback-url/open-note?id=6574EDEC-9EE6-464D-B957-576DB7A43161&header=Tables)

Copy/paste with Copy Link To Note in the note list now also works the same way as above: [[Welcome to the beta!]] – and also only pastes as wiki-link when pasted into other apps!!!

This must be a bug, or did I miss some settings somewhere?

1 Like

Continuing to play with Bear 2. Comparing my notes in Bear 2 to Bear 1… absolutely beautiful! Hiding the markdown, inclusion of tables, improved image handling, etc. I’m looking forward to moving into Bear 2 for real! :smile:

Bear 2 continues to exceed expectations! The search in images is awesome and feels like the feature that will seem unnecessary but will turn out being incredibly useful in finding content (e.g., I do a lot of screen capturing of presentations during Zoom calls). I noticed Bear 2 doesn’t find handwritten words in sketches, though Apple finds them and the handwritten words can be selected & copied from the image… so I’m hoping Bear 2 will eventually be able to even search handwriting within sketches. :sunglasses:

1 Like

We changed this recently following users’ feedback. The idea is for every note/header link paste as a wiki link inside the app and as a normal link outside the app. This way is easier to distinguish md links (edit icon at the right) and internal links when markdown hiding is in place.

I can’t simulate the second part, note links seem to paste as URLs (bear2://x-callback-url/...) in external apps.

This might be a good idea but I have to check how this will work with localisations.

Yes, we’ll going to add this.

I understand your point but We are very conflicted about introducing hover functionalities because they don’t work on iOS and cause UI elements to pop when you don’t need them.

Can you tell me which app works this way? I call tell Numbers doesn’t behave like this but maybe I’m missing something.

This is very hard to achieve at the moment.

I can simulate this issue but we also don’t have control on the special characters panel (is provided by macOS). I wonder if this is somehow caused by the shortcut your are using, I have ⌘⇧T.

Yes, this is something we have to fix.

Thanks for the feedback and your kind words!

A fair point. It’s possible that, had you implemented revealing section headers on hover, I would be asking for you to turn it off because of the visual distraction. :wink:

  • Google Docs (cursor moves to first column of new row)
  • Microsoft Word (newly added row is highlighted, but typing any character goes into first column)

I guess I think of tables in Bear more as adding a table in document than working with a table in a spreadsheet, so expected word-processor-ish behavior.

A good thought. I’ve always used ^⌘space to bring up the emoji panel (for me, ⌘⇧T means re-open closed tab :slightly_smiling_face: ). I haven’t found a way to reliably recreate the problem, but this recipe:

  • Alt+tab to another app and back to Bear 2
  • Type a word on a new line (e.g., "Testing ")
  • Invoke the special character dialog, select ⌘

In up to 25% of tries, the ⌘ character doesn’t get inserted as expected. FWIW, I’ve tried invoking the special character panel via :globe_with_meridians:E and through the menu (Edit > Emoji & Symbols) and have seen the same behavior. So, I don’t think the issue is related to the shortcut used. If I manage to reliably recreate the issue, I’ll certainly share.

Did you see this subsequent comment? I feel silly pointing it out, since the ability to search images & PDFs is already amazing… but, in case Apple makes it relatively easy to add, searching handwritten text in sketches within Bear 2 would be downright magical.

1 Like

Sorry, my bad :flushed: I can’t recreate that either – pasting bear-note-links to other apps actually works as expected :+1: Thank you :blush:

I’m not 100% sure but I think handwritten text recognition inside images (not scribble) is a private Apple API not available to third-party developers. Other libraries might require very large machine learning models or online API (potentially bad for privacy).

:white_check_mark: Confirmed fixed in Version 2.0 (9780). FWIW, so far with Version 2.0 (9780) I have not been able to recreate the “special characters fail to insert” behavior. While I couldn’t reliably recreate the issue, I could count on it showing up within 4-5 attempts. With the 9780 build, I’ve tried all kinds of variations (invoking the emoji & symbols dialog via ^⌘space, :globe_with_meridians:E, or via menu… switching between notes & other apps before inserting a symbol, etc.) and have not had a single failure to insert as expected. Yay! Bear 2 is getting even more stable!

:white_check_mark: Confirmed fixed in Version 2.0 (9780).

Partially addressed in Version 2.0 (9780). The Format > Footnote menu item is disabled within tables (good), but if you copy text containing a footnote or manually create a footnote (i.e., typing foobar[^1]) within a table cell, it renders as a footnote reference and clicking on the footnote reference opens up an obscure error message:

Thanks for the info. Yes, Tables still require some work.

MyScript has really good libraries for handwriting recognition, and they license them readily (e.g., Notability uses them). If you ever feel like you have the budget and the will, they are the way to go, quality-wise.

Very Interesting. As far as you know, the SDK works offline too or it’s a web API?
Web APIs are an easy no for us, because of privacy.

I’m pretty sure it works offline.