PDF Export Images Missing

Testing version: Version 2.0 (9695)

What were you doing: Export to PDF

What feature did you use: Export to PDF

What happened: Exported file is missing images and showing ugly markdown in its place.

What did you expect to happen: I would expect to either see the image as it shows in the preview or use just the filename or alt text as a placeholder.

Thank you for reporting this bug. We’ll provide a fix a soon as possible.

I want commit that I faced with the same problem in Version 2.0 (10084).

1 Like

Thanks for reporting this bug. Do you mind sharing the note in the screenshot as .bear for tests? Maybe via DM here on the forum.

Sorry, the file you are trying to upload is not authorized (authorized extensions: jpg, jpeg, png, gif, mp4, txt, rtf, md, mov, panda, textpack, zip).

Uploaded to the Yandex.drive: MBA General.bear — Яндекс.Диск

Thanks. I seem to get the PDF correctly exported and that might be because we already fixed the issue. To be sure can you please tell me more about how you exported the note and the macOS version you are running?

MacOS Version: 13.1 (22C65)
I tried export in two ways :

  1. Three dot in the top right corner → Export Note… → Export as: PDF
  2. Ctrl + P (the same File → Print) → in the left bottom corner “Save as PDF”

Result the same

I sincerely wish I can replicate this issue. Quick question, if you re-import the .bear file you sent and export the newly created note, do you get the same result?

Wow! No, re-exported .bear file exported correct and I see all attachments.