Show Markdown Doesn’t Work on iOS

Testing version:
iOS Version 2.0 (10939)

What were you doing:
Trying to enable Show Markdown

What feature did you use:
Settings > General > Uncheck ‘Hide Markdown’

What happened:
Had no effect in the editor. Markdown remains hidden.

What did you expect to happen:
I expected to have markdown displayed in my notes.

1 Like

I think this is a glitch:

Restarting Bear should make it work

It seems that you have to restart Bear to activate this and some other settings as well.

It doesn’t. It’s a bug.

I can confirm that the toggle does not show/hide markdown straight-away. I can also confirm that closing and swiping Bear away, then reopening does resolve it.

I am not sure how the toggle is expected to work but did think that just by triggering it that my notes would automatically adjust without a restart of the app.


Yes, I agree.
I called it a glitch, meaning a bug or oversight :sunglasses:

I know this is a long dormant thread, but has this ever been addressed? It’s still an issue for me over a year later . . .

I don’t have recent reports of this issue and I can’t simulate the issue on the current beta. Do you mind telling me more about what you are experiencing?

Basically, the feature “Hide Markdown” under Settings>General doesn’t change anything about the function of the app. Screen recording on iPad -

Oh I see. Turning off Hide Markdown doesn’t actually shows all the markers but force the editor to use the Bear 1 styling, meaning the inline markers are visibile while others, such as headers, quotes and lists don’t show the markers but text attachments.

Can you explain that a little more/differently? I understand some of what you are saying (I’m new to Bear and evaluating if I want to pay for it or not). Also - if it isn’t as simple as “show/hide ALL markdown tags,” I think it needs helper text explaining what it DOES do.

Sure, You can split MD markers into Inlines and non-inlines.
**bold** or ==highlighted== and everything that can be expressed in a paragraph without changing the style of the whole paragraph is inline. # headers, > quotes change the style of the whole paragraph to fall in the second category. Bear 1 showed the inline markers but hidden non-inline with text attachments as in the screenshot.

Screenshot 2024-04-24 at 09.54.36