Text paragraphs inside list items?

Not sure this is a bug or not so putting in Feedback.

In markdown it is easy to have a list item with a paragraph of text “inside” it by doing a shift-enter (in most editors) twice after the list item. This has the text indent properly with its “parent” list item.

This does not seem possible in Bear unless I paste in from a document outside of Bear. Ctrl-Enter (why folks?) seems to sorta get there but exported markdown apparently isnt correct per Marked 2.

I dont recall if this is possible in Bear 1.


See Basic Syntax | Markdown Guide

I’m able to replicate the behavior you’re describing, but I also found a workaround:

  1. Shift-Enter at the end of the bullet list item
  2. Option-Space (this works on Mac, not sure about PC) to create a non-breaking line space
  3. Shift-Enter one more time
  4. Type a paragraph
  5. Hit enter if you’re done and want to write a new bullet, otherwise repeat steps 1 - 4.

If the non-breaking space thing doesn’t work, you can also just write literally any character after the first Shift-Enter, then Shift-Enter one more time and start writing; you can go back and delete that character, and the rest of it still works.

I know this is not ideal, and pretty good feedback.

Thank you! Unfortunately I can’t do opt-space because Alfred is configured for that :rofl: But yeah I can just do another letter for now and then delete it. I don’t do this often but it was frustrating so thanks much for the work-around!

1 Like