Bear 2.0 (9652) - App Crashes When Editing Tag

Found a weird bug. When installing Bear 2.0, some of my tag icons after the import didn’t match my 1.0 tags. So I decided to delete the tag icons (basically just resetting it to the hashtag icon). I was able to edit the tag icon for all sub tags except the one shown in the attached file. When I attempt to edit that “Retail” tag, Bear 2.0 crashes. Simply choosing Edit Tag crashes the app. It happens every time.


thanks for reporting this crash, can you please send me via DM the latest Bear crash log you can find on your mac?

Best Regards.

Earlier today I found Bear log files but they weren’t titled “crash” logs. Are they one and the same?

Yes. Eventually you might find beta specific logs here ~/Library/Containers/net.shinyfrog.bear/Data/Library/ Logs /Bear/

Done. I DM’d you. Thank you.

Just submitted two MacOS crash reports about a similar issue (though I’m on Version 2.0 (10641)). Changed four or so tag icons in a row, no problem. Then tried to change one for a tag that includes “blog” and was given a default, non-hashtag icon. The app crashed. Upon reopening, I could change the “blog” icon but the app crashed when I tried to change a second icon. Ditto upon reopening—I can change one, then the second crashes. Happy to DM logs if necessary.