Bear Search widgets not listing any notes with @... searches

Testing version:
Bear 2.1.4.(12484)
on iPad Pro 12" (2nd gen) running iPadOS 17.3.1 (21D61)

What were you doing:
Adding Bear Search widgets

What feature did you use:
Tried all 3 search widgets with either @pinned, @last2days, or @yesterday.

What happened:
No notes listed, but search opens in Bear when tapping empty widget.

What did you expect to happen:
Listing notes in widget according to @… searches. (Works with regular plain keywords)


Thanks for reporting this but the search widget seems to work fine here. Does the search widget for regular searches work as expected?

Hi Danilo, thanks for swift response :slight_smile:

  • Regular search keywords lists really old notes but not from from last several days.
  • Got @last10days to list some notes, but @last5days doesn’t list anything.
  • Same issue on both iPhone and iPad.
  • The listing in widget (when I manage to get it to list something) and same search inside Bear, lists very different results and order.
  • @pinned doesn’t list anything even though one of the pinned notes is from november.
  1. Did a clean reinstall on iPhone
  2. Waited to all notes had synced rell
  3. Re-added the largest search widget
  4. Tried @last350days: nothing listed
  5. @last360days: a few notes from March last year were listed.
  6. Edited one of those, and now that one only get listed with: @last350days and also appear as the only one with @last1days :thinking:
  7. Edited a recent note, but that didn’t appear in the list …

Does the Widget rely on Spotlight search?

No but, How many notes do you have on your library?

1,175 notes only, starting from October 2010.

Using Widgget with empty search:

  • I expect list of last modified notes, but now on iPhone the top one is from March 5th last year
  • On iPad i get a different result with empty search: notes from last month, but not the latest ones.
  • Also noticed that when added search widget, it searches for “Bear” by default, even though the search field is empty :thinking:

In IOS Preferences > Privacy&Security > Analytics & Improvements > Analytics Data can you see some “Bear” or “Bear Widgets” crashes?

I see a bunch of these:

and on iPad;

But it doesn’t look like any of these are recent. BTW I’m not running the beta, but latest AppStore release. Would it be helpful if I tried with latest beta from TestFlight instead?

Did a clean install of Bear with restart in between on my iPad as well, and now get the exact same result as on iPhone.

  • Blank search shows only notes older than 357 days,
  • @last350days lists nothing
  • If I add or edit newer notes, they still do not show up in widget list.
  • If I edit notes older than 357 days, they do show up with @last1days in search field.


  • Did a full backup and restore of Bear on Mac
  • Waited for Mac to complete sync up to iCloud
  • Waited for iPhone and iPad to sync down from iCloud
  • Search Widget now works as expected :+1::sunglasses: