Copying rich text from Bear to editor loses indents

PS. as CyndiBidar writes above, it didn’t really work with copy a Rich Text and paste into Word.

I reported that it worked with Word, but it’s not a real bullet list. When I looked at it more closely, it seems to be a “mockup” list made out of tabs, bullet like symbols and text.

It has the nested indents but otherwise doesn’t behave like a Word list.

And as Cyndi says, it used to work from Bear 1.

I don’t know if this was helpful, but anyway …

I also noticed that copying a list from Word and using Paste From Rich Text in Bear 2.0:
The bullets are not converted to propper Markdown tags - dash but something that looks very similar to - dash, and is probably some kind of unicode lookalike.

Also first level of list is indented with tab so the whole list becomes code blocks.

Ok, I think I got a more satisfying result for all the target apps and fix also Cyndi’s issue.

Thanks for reporting this and for the info. The fix will be available with the next update.

1 Like

Thank you! Really excited to get this, as writing in Bear and copy/pasting to Confluence/Google Docs/Slack is my most common workflow.

And each app using different symbols for different levels of indentation is totally expected, so that’s no issue. Thanks again!

1 Like

Just installed the new update. Indents are now working as expected. Thanks for fixing this!


The bullets are working great in Google Docs and Slack! But still the same issue in Confluence :slightly_frowning_face: Any guesses there?

Secondly, I noticed that in all apps, when copying headers as rich text, they get pasted as bold text instead of headers. Is that working as designed?

I can see it works as expected if I copy a list from Notes but I have to investigate.

Unfortunately, yes. RTF doesn’t have the concept of “Headers” and the apps have to work on the text size and other parameters to guess what’s a header and what’s not.

1 Like

Sounds good. If it helps, if I export a note as a Word doc, and then use Confluence’s Word import feature, it works perfectly. It’s just the copy/pasting rich text that does this.

I’m not sure to what extent this is considered fix, but copying a bulleted list from 11093 and pasting into Apple Mail completely flattens the bullets, and pasting into a TextEdit rtf document mostly preserves indents, but has some levels with missing bullets. I can provide more details/examples later if needed.

1 Like

This was painful but I think I fixed the paste of lists on Please give another round of rich text copy and paste with the next update.


@trix180 any work done on this for Confluence by chance?

Yes, pasting lists on Confluence seems to work as expected now.

1 Like