Copying rich text from Bear to editor loses indents

Testing version: Version 2.0 (10209)

What were you doing:

this on pasting (via rich text copy) is resulting in:

What feature did you use: copy Rich text

What happened: Regression in indents/formatting when paste a rich text copy

What did you expect to happen:
In Bear 1, it shows nicely with indents on pasting. Can’t upload this as limited to only 2 embeds.

In Bear 1, it shows nicely with indents on pasting. Can’t upload this as limited to only 2 embeds.

You are using a very old release. Do you have access to the TestFlight versions?

I read that test flight will only run for 30 days (and was not sure of what will happen to the data post this).

Also tried today with Version 2.0 (10784) but the issue persists.

Doing a rich text copy:

On Pasting, it still loses the indents:

What app are you pasting it into?

Can confirm, this happens to me as well. Happens when I paste into Slack.

It is a interview feedback portal. but should be reproducible in gdocs and slack as well.

Yes, see the same issue here too.

For some reason, it does work when pasting into Word and Pages, but does not work pasting into Outlook, Mail, or Google Docs.

It even fails round trip: Paste From → Rich Text back to Bear itself!! ??

@trix180 Same problem on Mac and iOS/iPad

Just want to add that this bug is actually really painful. It makes it really difficult to actually use Bear for writing and then move text to other places where other people need to see it, which is a super common use case.

1 Like

Yes, something odd is definitely happening here but I’m confused because I don’t get the result shown here (but another which might not be desirable as well).

In Google Docs for example I get this

Maybe the tabs can be improved here but I can see the indentation is working correctly. Am I missing something?


I think the copy as Rich Text may work differently if the list tag is - instead of *

Also try the round trip in Bear:

  1. copy as Rich Text
  2. Paste from Rich Text

:thinking: I seem to get the same outcome.

This is kind of ok atm because of the leading list tabs, that can be eventually removed but I’d like to simulate OP bug first.

But should there be a leading tab on first list item as well?

I assumed that a round trip: Copy As → Rich Text and then Paste From → Rich Text, inside Bear itself, would be the litmus test that those two are working correctly?

Anyway, copy and paste into Word and Pages seems to work correctly.

If it’s working correctly on Word and Pages I’m pretty sure the leading tab is required, but again this is not what I want to address first.

No, this is not expected, or at least not for all the possible cases. Bear and Panda use their internal clipboard for this specific purpose.

Here are 3 copy rich text & pasting examples. In every case, notice that it’s not actually pasting rich lists. It’s just indented dots and dashes that look pretty bad (except in Slack, the top level bullet is a rich bullet, but the sub-bullets are not).

Here is the text I copied as Rich Text from Bear.

Here is what it looks like when I paste it into Slack.

Here is pasting into Google Docs. Same result happens when copying into Microsoft Word.

Here is pasting into Confluence.

1 Like

Looks like with Bear2 testflight, i can’t install Bear 1 anymore without uninstalling and losing my recent data. Any updates on getting the format working would be great!

I have just finished a fix for this issue but I must provide some context. My testing is based on the rich text copying from Bear to GDocs (Chrome), TextEdit (RTF mode), Slack, Pages, and Word.

Word seems to not manage the RTF lists very well or not as the other apps. You can try making a multilevel list in TextEdit and paste it into Word to see the results. I’m aware the above used to work in Word with Bear 2 but I’m not able to have it work for the other apps and Word. This is what concerns me the most about the fix but I have to rely on user feedback. Bear 1 kinda works if you don’t use deep multi-level lists.

Results for other apps are coherent with the original list but some replace the list items (circle, square, dot, …)

Screenshot 2023-04-14 at 16.49.27

Screenshot 2023-04-14 at 16.50.22



If you want to report other apps to test I’ll be glad to give it a shot.

Is this fix already released in 10816?

Another repost on the same issue:

no, as I wrote I have just finished that and running some tests.

1 Like