"Update Error!" when Checking for updates

Testing version:


What were you doing:

Ran “Check for Updates”

What feature did you use:


What happened:

Got an error saying “Bear can’t be updated if it’s running from the location it was downloaded to”

What did you expect to happen:

That Bear checked for updateds.

I have installed the app in ~/Applications, shouldn’t this be supported or?

You can place B2 app on your desktop or any other subfolder.

But why not inside ~/Applications? Where it is supposed to be…

btw, tried to move it under ~/Bear2 but got the same error message.

I somehow misinterpreted your message. Yes, it can stay in /Applications. Do you get the message even if you quit Bear and restart from /Applications?

I have it inside my home folder: /Users/“username”/Applications/Bear.app and I also tried using /Users/“username”/Bear2/Bear.app. (i.e. not under /Applications)
Was using ~ to indicate my home folder…

Yes, I have tried to restart it from the locations mentioned.

I’m a little puzzled about the problem you are experiencing but I have found a workaround suggested on the site of an app that uses the same updater library.

  1. Go to Applications and find Bear.
  2. Make a copy of Bear to Desktop.
  3. Move the copy of Bear in Applications to the Trash.
  4. Move the copy of Bear from Desktop to Applications.
  5. Launch Bear again and try “Check for Retrospect Updates…​”

Can you please give it a try?

Tried that but got the same error.