All notes with attachments fail to render properly on macOS

Testing version: Version 2.0.11 (11968) on macOS Sonoma RC.

What were you doing: Trying to view notes with images etc on macOS.

What happened: any note with attachments like images render with just tons of empty space, all the text is missing, text cursor is missing, I can type text into note but I can’t see my typing, and all images are not displayed. I noticed this happening after updating to latest 2.0.11 (11968), I’m pretty sure the prior version was fine even on Sonoma.

I tried to quit and relaunch the app, reboot the MacBook Air M1 I’m using Bear with, disable and re-enable sync, but the rendering issue persists.

What did you expect to happen: notes should display normally on macOS.

This how it looks on Sonoma RC:

Same note on iOS 17 RC:

1 Like

I’m having this same issue - However I’m using Sonoma RC on multiple machines, and the only one that has a problem is the machine that was also running the Bear Beta in the past.

One issue I did see that might have caused this problem, I went from what I think was an older Test Flight version of Bear 2.0.+ - and installed the app store version via the App Store. (Other Sonoma machines never ran the beta via test flight, just installed Bear from the App Store, and they work fine.)

It seems like the “cloud” is correct and this machine has the issue. Is there a way to completely delete the Bear install from this “Ventura → Sonoma previously running the beta” mac? And just start with a fresh install and sync from the app store?

I’ve also installed this version over the TestFlight version, and only after the recent update I noticed the rendering issue. It was fine until now.

Hi folks,

we’re looking into this, we’re still not sure what’s going on and we’ll update asap.


1 Like

Following up - I upgraded my ‘clean’ Bear app install on MacOS Sonoma - to 2.0.11, and that causes the issue. So my earlier comment about the Beta is probably wrong. It’s 2.0.11 - at least on Sonoma.

We found the issue, building Bear with the latest Xcode has broken the editor on Sonoma. We’re trying to push a fix as soon as possible.

Thank you for all the feedback.


Classic Xcode. Thanks @matteo for the quick response.

I hope this isn’t an instance of Apple ‘not finishing macos until X is broken’ :slight_smile:

Good news folks, we managed to find a workaround and fix the issue. We’ll try to ship an update in the next couple of days.


is there any workaround before the next version shipped?

Would it work if we uninstalled Bear and placed an older version of the app into Applications folder? That would of course mean we would have to have access for the older app, which isn’t possible via App Store. Someone would have to share it.

If you had Time Machine backup (I don’t), you could probably roll back into an older version.

Yeah I’d love to know if there’s any way. A lot of my notes are inaccessible on Mac now.

I tried this - and it didn’t work. I think the issues is 2.0.11

Hi folks,

we just released a new update that should solve the issue!



Thanks I appreciate it.