App Crash, Lost Formatting, Lost ability to Edit, Losing Notes

Testing version:
Version 2.0 (10084)

What were you doing:
Editing a note with:

  • a list
  • an external link in that list, in addition, that link was to a subsection on that external web page.
  • a command in back tics in that list like: this

What feature did you use:
Just editing

What happened:
The app just crashed and went away. Upon restarting, there’s no formatting to text on any notes - maybe using a system font? I also can’t edit text. When I try to edit, I get a beach ball, or a crash…

Right before this happened - the note I was editing - I’ll call it the ‘offending note’ looked like indentation was a bit messed up - that external link was in a list, but was not indented like the other text in the list.

I see that now - if I try to open any other note - that note content gets replaced by that ‘offending note’ - and seems to be gone - so now I’m getting multiple copies of the ‘offending note’.

If I try to delete the ‘offending note’ and empty trash, it’s still there… and still there if I close and reopen Bear.

If I try to export the ‘offending note’ - Bear crashes.

Also, every time I reopen Bear - the latest note in reverse chronological order gets replaced by the ‘offending note’… Just like when selecting one.

FYI - I have a backup of notes using bear_export_sync from last night.

FYI - I also tried to copy the ‘offending note’ into Panda, but had a command noting that version expired and I had to update. Coincidence?

What did you expect to happen:
Typical Bear behavior

Any tips to how I can get back to working with the beta?

1 Like

Interesting, I got exactly the same behavior today!

Happily I had recent backup so just restored it and everything went back to normal (still lost a bit of work though).

The only unusual thing I tried to do was unordered list inside a quote, something like

> * item
     another line

But I wasn’t able to reproduce it later.
(Though note was quite big and contained a lot of other formatting like tables, internal and external links so could be anything.)

Also sometimes I notice weird behavior like freezing when I’m editing a table, or crash (if I remember correctly) when editing similar list/quote structures.

But “that note gets replaced by that last ‘offending’ note” happened to me for the first time :smiley:

I’m not sure about the priority, but I’d call this a Sev1 bug.

1 Like

One more follow up - I think Bear 2 crashes with a certain set of characters in the same line. I copied from the ‘offending file’, pasted it into new file in text edit, saved as md, then tried to open it in Panda - and it won’t open. In fact, no other file opens in Panda after that unless I quit Panda and start again.

I can send it to you, but am hesitant to post it here… as it seems to be toxic to Bear 2. Let me know!

Yes, something definitely problematic is happening for that particular text. Any chance you can share the MD file privately with me for testing?

Regarding keep working with the beta, you can delete ~/Library/Group Containers/ Data v2 and restart the beta.


One other follow up - I deleted the ‘offending file’ (and copies) in the underlying sqlite db and was working again.

For any lost notes, I just replaced from a backup… I didn’t want to lose my doc edits in the beta.