Can't paste a non-ASCII character into a table on macOS

Testing version: 10936(macOS) & 10939(iOS)

What were you doing: pasting into a table in MacOS

What feature did you use: copy & paste

What happened: macOS - a string containing “➤” would copy then paste into the body of the note, but not inside a table - nothing was pasted. In iOS I was able to paste that same string into the table. Back on MacOS, the string appeared in the table via sync. When I then tried to copy and paste that string to a new cell in the same table, the MacOS app crashed.

What did you expect to happen: normal paste into a table as happens in the body of the note.

1 Like

I tried recreating this. It looks like the specific character or involvement of iOS are a red herrings. The actual problem from my testing appears to be the inability to copy text within a table in Bear 2 beta Version 2.0 (10936).

I created a new note in Bear 2 beta on macOS with a simple table:

a b
c d

Trying to copy any of the letters fails (selecting any letter and pressing ⌘C or selecting Copy from the context menu) fails – nothing goes into the clipboard. Using any of the Edit > Copy As menu options (plain text, rich text, markdown, HTML) clear the clipboard (maybe puts nil value into the clipboard?).