'Check spelling while typing' re-enables itself randomly

Testing version:
Version 2.0 (9735)

What happened:
Spellcheck re-enables itself randomly.

What did you expect to happen:
If I disable spellcheck, it should stay disabled. Bear should respect the macOS setting where you can disable spellcheck system-wide.

I take notes in multiple languages, and some of my notes are just a sea of red squiggly lines when the spellcheck thinks those are typos. Disabling ‘Check spelling while typing’ gets rid of those lines, but it gets re-enabled randomly. This has happened maybe 3 or 4 times in last week or so.

I have also disabled spellcheck in macOS keyboard settings, and Bear should respect that setting, right? But when I launched Bear for the first time I noticed that spellcheck was enabled.


Hello and sorry for the late response,

I do find how macOS handles the spellcheck and other text view flags confusing. Take a sys app like TextEdit, my expectations sometimes are the flags I set via Edit > Spelling and grammar in the menu are preserved across all the documents opened but those settings are applied only for the current document. New docs opened with TextEdit takes the flags from the System preferences. I think this is over complicated and is kind of hard to understand when the Sys preferences are used for documents based or shoebox apps.

The current handling in Bear 2 of those flag has some issue and we’ll provide a fix as soon as possible, but will not work as you suggested. Our idea is to make the only “source of truth” the Edit > Spelling and grammar menu but, if those options are left untouched, the sys preferences are applied.

1 Like

Yeah I agree it’s kinda confusing what applies and when on macOS in general. Since writing this the spelling options haven’t re-enabled themselves anymore, so I’m not sure what happened there.

I think the way you describe how it should work is great and logical, thanks.

1 Like

@trix180 after updating to 9933 the spellcheck while typing enabled itself again. Maybe that’s what I was seeing the whole time; disabled spellcheck turns back on after an update?

Hello. :thinking: I don’t see why the update should erase the preferences. Any chance you used some app to delete Bear and related files before the update?

No I haven’t done anything like that. But it turned itself back on that’s for sure, but maybe it wasn’t the update that triggered it. I just noticed it after updating, but should have checked what the state was before triggering it.