Copy as rtf not working in iOS

Testing version: iOS 2.0.7 (11876)
iPadOS 2.0.7 (11876)

What were you doing: copy Bear note as rtf and paste into Apple note

What feature did you use: Bear note “copy as rtf”

What happened: after copying as rtf in Bear, nothing appeared when I tried to paste in Apple note; also tried to paste into other apps (Drafts, Apple Messages) and nothing appeared; the only way to copy and paste as rtf is to select (highlight) the whole note and then choose copy from the select pop-up menu

What did you expect to happen: the note I copied as rtf in Bear to paste into an Apple note and other apps - this function works as expected in Bear for Mac

Thanks for reporting this. Does this problem happen for any selected text in Bear or just some particular string?

Thank you for responding so quickly. It happens when I tap the 3 menu dots in the upper right corner of a note and choose “Copy as…” and pick RTF and also when I long press on the note in the sidebar and choose “Copy as…” RTF. Then after doing either of those things, I try to paste in another app and nothing pastes. Nothing happens. If I go into the same note and “Select All” and choose “Copy”, then it will paste into other apps. I can also select a portion of a note and choose “Copy” and paste successfully into other apps. The other “Copy as” options in the 3 dots menu and the long press on sidebar work as expected - plain text, markdown, HTML. (The “Highlighted Parts Only” doesn’t seem to “copy as” either, but I never use that so I don’t know what the expected behavior is.) I hope this makes sense.

1 Like

To clarify: It happens with all my notes when I try to use the “Copy as…RTF” function to copy and then paste an entire note. Copy and paste works when I select a portion of a note from within the note. Thank you


This is happening to me too.

@danmills7 @ourliz This bug will be fixed with the next update. Thanks for the report.