Copy & paste from Apple Notes worked well

Subsequent attempts at folding did not. Sometimes folded text merged with other text, Sometimes worked as expected, sometimes disappeared.

Hi and Welcome,
do you mind sharing a video of this bug? We might have some idea of what it’s happening but a video will make it easier for us to simulate and fix the issue.


I spent the day trying to reproduce this and came up with these observations. (1.03 KB)

Thank you for the file. I think some encoding problem is happening when the text is copied from Notes however how this happened it’s not clear to me. Please create a new TextEdit document, hit ⌘⇧T to enter RTF mode, copy the Notes content in it, and save the file and share it here. Hopefully, this will help us understand what’s going wrong.

Sorry. Is this better?

Import from Apple Notes


  • cleaner interface than Apple notes
  • subscription ($10/yr), will try a year
  • no mac version (yet)
  • excellent, but needs another year of work

Roam Research

  • a true writing app
  • stores everything on the web, not locally
  • no mobile app
  • can’t login for more than 2 weeks without paying
  • potentially useful link map


  • similar to Roam
  • essentially a markdown editor
  • stores locally as a markdown document
  • Mac beta seems to lack list folding as yet
  • no mobile app yet

Steps used in making this

  1. copy/paste from Apple Notes
  2. convert headings into Panda headings - failure to do this will cause Panda to assume all lines below current heading are list items
  3. when a heading is closed, the following heading is placed on the same line


Hi, unfortunately copying and pasting the above in Notes and then in Panda (or directly in Panda) doesn’t seem to produce the same problem. Any chance you can attach the RTF file?