Exact Search Bug

Testing version: Version 2.1.8 (12574)

What were you doing: trying to search for an exact term

What feature did you use: exact search using quotes

What happened: when doing a normal search in a note the search returns a result, but when you use quotes to perform an exact match search it returns no results (as seen in screen shots below)

Screenshot 2024-04-05 at 11.00.29 AM

Screenshot 2024-04-05 at 11.00.38 AM

What did you expect to happen: when you surround a search term with quotes it would result in finding the precise search term

That’s the search inside the editor, and it’s supposed to work that way. You’re searching for "exact" quotes included :slight_smile:

I’ve just tried a bunch of editors (from TextEdit to Xcode) and they all behave the same, let me know if you’re using an app that does it in a different way!

1 Like

Thanks for clarifying, I didn’t know the search behavior worked different in the notes list vs the editor. Are there any other differences in how the search notation functions?

Since we’re about the subject of search, would you have any news as to having Quick Open behave as the search field and wiki links autocomplete ? :blush: