Importing still misses some tags

Testing version: Version 2.0 (9735)

What were you doing: Importing database from B1

What feature did you use: Nothing; just import

What happened: The very 1st beta missed a lot of tagcons, the 2nd did better, the 3d is almost perfect but still misses a few. I copied the text with the tags to BBEdit to see if there’s perhaps a specific “type” of tag formatting or hidden text even that could be the culprit, but it’s purely random it seems.

What did you expect to happen: All tagcons to be imported.

Same here,

For reference, this is Bear 1 vs Bear 2 for me.
Notice tag cons for books and school missing under @ and
mathematics and psychology missing under #1 and
music missing under #5.

By looking at the screenshots reported here and in other threads my suspect is the missing tagcons are the ones automatically associated by Bear. For example in @Eleanor screenshots 0,1,2 tagcons required user actions to be associated while school, mathematics, psychology, ... are automatically associated with the tagcon in the screenshot.

Automatic tagcon association works using the device’s preferred languages (System Preferences > Language & Region for macOS) and a special dictionary of translation we have inside the app. Can you please tell me which preferred languages you are using?

This and any bug concerning migration are way easy to simulate if we have the database.
If someone is willing to share his/hers B1 database with me please contact me via DM.

1 Like

That makes sense :smiley: Perhaps those are the ones that the tag cons are automatically set and I didn’t change cause I liked the way it is. Mine is set as English (Australia)

Mine is English United Kingdom.

I’m sending you my database…

Hi Danilo,

I tried sending you the Application folder and it’s too big — but am I right assuming that it doesn’t contain the notes themselves? Don’t you need the actual SQLite database?


Erik Vlietinck
Freelance journalist and content writer for Fortune 500 companies and SMEs.

Thanks, Erik, but I think we solved the problem with @Eleanor help. I’ll send you a build to confirm you now see the missing tagcons.