[Korean Language] Autocompletion for Quick Open/Linking notes/Tag entry in Korean doesn't appear immediately

Testing version:

  • Environment
    • Mac Sonoma 14.3.1
    • Bear 2.1.4
    • The input system is Korean(2-set)
      image 10

What were you doing:

Using Quick Open/Linking notes/Tag in Korean language.

What feature did you use:

Quick Open/Linking notes/Tag entry in Korean language

What happened:

Autocompletion does not work well when using quick open / entering tags / linking notes in Korean language.

  • When using Quick open or entering a tag / linking a note in English, auto-completion suggestions appear as soon as you enter just one letter.
  • However, when you try to enter a tag or link a note in Korean,
    after entering text(one Korean syllable) → press the Space key once → Backspace again to erase the empty space → then Autocompletion suggestions appear.

What did you expect to happen:

Quick open suggestions, Auto Complete Tags or Notes should work like It works in English

  • ps1. It works fine on iOS (iphone, ipad).
  • ps2. Same features work fine on Other apps(Upnote, Obsidian, Apple notes, Agenda etc.)

Detailed description with pictures

Quick Open

Linking notes

  • typed “[[데” → Doesn’t show the results.
    image 5

  • typed “[[데” + left arrow key → Doesn’t show the results.
    image 4

  • typed “[[데” → space bar → backspace to erase the space → Shows the results.

Hash tags

  • typed “#데” → Doesn’t show the results.
    image 8

  • typed “#데” → space bar → backspace to erase the space → Shows the results.
    image 9

Hello and thanks for reporting this problem. We’ll check it as soon as possible.

1 Like

I’d appreciate an update on the development status of a fix for this issue.

Can you please confirm you are running macOS 14.4.1 and Bear 2.1.8 and experiencing the same issue?

If this is the case, is your input system set as follows?

We can’t get the blu underline as in your screenshot when composing the text and I wonder how your system is set.

Yes, I use macOS 14.4.1 and Bear 2.1.8 and experience the same issue.
and my input system is the same as you set.

I don’t know why you don’t get the blue underline,
But I get the underline almost everywhere on Chrome, Arc, Bear(blue), Upnote, Obsidian(Black or White depending on themes) etc.

Apple Notes and Spotlight don’t display the underline but the input behavior seems the same.

The Korean language has a combination system, unlike English.
(maybe CJK languages have a combination system, CJK: China, Japan, Korea)

the underline indicates that the letter is still being assembled.(or could be assembled or finished)

Since Korean syllable blocks can contain 2, 3, or 4 Korean letters, and always have a mix of consonants and vowels like this below.

We never know if I’m typing “가”(2 letters) or “갑”(3 letters) or “값”(4 letters) until It makes an intended combination.
What I notice is that Other apps try to search every time I type a single letter.
for example, If I’m typing “값”, Obsidian search “ㄱ”->“가” → “갑” → “값”.


  • on iOS, IpadOS,
    • everything works fine.
    • every app doesn’t show the underline when typing.


1 Like

Thanks. We understand how the combination works (in a programming sense :blush:) and we suspect the underline is the key to understanding what’s happening here. I’m quite puzzled I can’t get into the same situation. Can you please tell me your preferred languages in Language & Region in the system preferences?
Are you using your laptop’s keyboard or an Apple keyboard?

Thank you for your efforts to resolve the issue. :smiley:

  • My preferred language and Language for Bear is English.
  • Language & Region: English, South Korea (I don’t think Region matters though)
  • I use my laptop’s keyboard, no additional keyboard. (M1 Macbook Air 2020)

Repro steps

  • I just restarted my Macbook to test again.
  • I noticed when I type for Backlinks, Quick Open, It worked well for a while.
    • I could write Korean properly, Quick Open results and Backlinks appeared as I typeed,
  • When I tried Hashtag, a consonant and a vowel didn’t make a combination properly,
    like #ㄷㅔ when I tried to type #데.
  • So I deleted and retyped and It made proper letter combination (#데 )
  • After that, the blue underline appeared.
  • And Backlinks, Quick Open don’t work properly like before.
  • I quitted Bear app and restarted the app again. the blue underline appears.