Pasting more than one item from iOS clipboard doesn't work

Testing version:
iOS 2.0, 11163

What were you doing:
Copying multiple items into clipboard. Pasting clipboard content – multiple items – into a note.
I checked 3 scenarios:

  1. copy multiple photos from the iOS gallery
  2. copy multiple images from the Files app
  3. copy multiple PDF-s from the Files app

What feature did you use:

What happened:
Only one item from the clipboard has been pasted into a note.

What did you expect to happen:
All items from the clipboard should be pasted into a note.

Screen recording showing what I mean.

1 Like

But that’s the way the clipboard works. A standard clipboard can only hold one item. You would have to use a third party clipboard utility that can hold multiple items to accomplish what you want.

Not the fault of Bear.

@sgtaylor50, I’m not trying to somehow force the clipboard history into existence – I’m not copying multiple items one after another but I first select several items, then I copy them (in one click, so the clipboard contains multiple items.

Sorry for the confusion.

On macOS, what you are describing works. I just tested it.

On iOS, Share the items you’ve selected (I tried selecting multiple images from Photos) you will see one image and there are multiple lozenges at the top underneath the title bar. Each lozenge is a selection for an image or file. You need to scroll the lozenges selected to the most rightward one, it’s collapsed, but means “all images”. That worked.

Does this help?

Thank you for the time you spent trying to help me, but I’m afraid I don’t understand what you’re describing in the latest response. Maybe I was not clear enough in my description, that’s why I updated the first post with the screen recording.

Yes, something was wrong with multiple items paste. This will be fixed with the next update.
Thanks for reporting this bug.

1 Like

I see that the developers are fixing the problem. I use “share”:

Share from your initial app, then

and then “send”