Tags - Yikes! What's happened?

Not sure if this is a bug in 2.0 or expected behaviour but I use a lot (and I mean, a LOT) of nested tags to organise my notes. In Bear 1.x, I could type part of a root (or second) tag and if I’d used it before, it popped up in the autocomplete allowing me to easily select it and then append the new tag.

In Bear 2.0 though, it’s now a real chore adding new tags as it seems to autocomplete the top item and you have to be careful and precise to delete the unwanted tags.

So, for instance (as this is a little hard to explain), below is a small extract of one of my tags,

Development\PowerShell_my functions

In Bear 1.x I could type #PowerShell then just append any new tag.

In Bear 2.0, when I type #PowerShell, as soon as I type a ‘/’ after it, it auto-defaults to the top item which is Development/PowerShell/_Modules/Azure Az/Connect-AzAccount, so I need to delete the ‘_Modules/Azure Az/Connect-AzAccount’ each time. I can’t even type in #Development/PowerShell because as soon as I type the ‘/’ after Development, it auto-defaults to Development/MS-DOS/chcp/

Hopefully this is just a bug and can be easily squashed.


I experienced that annoyance too. But i do not thin that it is a bug but just how the things work. In total tag writing is more comfortable in bear 2 than in bear 1. But this should be adressed somehow, maybe to have the written tag from editor as first entry in autocomplete list

Have experienced this as well and hoping that it is not the expected behaviour

Adding my plus 1 to this. I also hope this is a bug and can be fixed.

For my use case I have a tag for each day that looks like dates/yyyy/mm/dd and I task type mm/dd to get to it quickly but I run into the same issues as OP

Adding a +1 to this. I just switched over to Bear 2 yesterday and love it so much. Today I was editing a bunch of notes and really working in Bear 2, and I keep hitting this issue.

To me, the auto-complete should happen when I hit return, and if I hit / then I should be able to continue typing out the full tag. This is how it worked in Bear 1, so I expect this is a bug.

1 Like

I’ve been having this too, but only with one particular set of nested tags: typing the / seems to trigger autocomplete, except it’s not real autocomplete, as it won’t add the trailing # for subtags with spaces in.

In my case the top item in the autocompletion list isn’t even the first subtag, it’s an arbitrary one — but always the same one.

And, as mentioned, for me this only happens for one particular tag — most of my nested tags behave just fine, so I think it’s safe to trust that this is not the expected behaviour.

I haven’t been able to figure out what it is about this tag that causes it, though, unless it’s just that it has a lot of subtags. Renaming the tag means it’s still broken. Weirdly, renaming it changes which subtag gets autofilled; but renaming it back changes it back to the same original one. Deleting the subtag that was getting autofilled just means another one gets autofilled instead.

Looks like this has been fixed in the latest updates, yay!


Yes indeed, can confirm from my end that this is fixed! :tada:

Yep, all working as expected now. Appreciate the quick fix on this one dev team!

1 Like