Unable to select Single Note in Bear widget

Testing version: 2.0 (11586) also iOS 16.5 (not 17)

What were you doing: Adding single note widget to iPhone and iPad

What feature did you use: iOS widgets

What happened: can add the the widget but the note is fixed i.e. unable to select the note that I want to display

What did you expect to happen: option to select a specific note in Bear.

Did you press+hold > edit > Bear? I can (at least on 16.5.1) to select my individual note (same bear build)

Also 16.5.1.
Yes, I get the option and can see the selected note.
But when I click on the selected note in the ‘Pick a single note’ section, nothing happens i.e. I don’t get a list of notes to select from. I’ve deleted the widget, restarted the phone etc. Previously this has worked fine.

Which size widget did you use? Wonder if that has any impact. Only other difference I could think - I added my widget to a stack, instead of standalone.

I’ve tried various sizes - stack and stand-alone - the bug persists.

I can trick it by pinning and editing the note that I want in Bear such that the widget selects is as default, but I figured it’s worth reporting.

Yeah fair enough - was just curious as I wasn’t able to replicate, so wanted to help determine if it was local issue or not. Have you made application backup, cleared data, tested with a fresh note or two? Obviously at the end you can restore app data.

Settings > Advanced

I haven’t specifically tried this, but if it works as I expect this should allow you to test with no loss of data. I’m happy to give it a try if you are not confident?

1 Like

Hi, can you try to reboot your device? If this doesn’t work, please tell me if you have a large collection of notes.

Working briefly again on iPad, for no apparent reason, and then stopped. Still not working on iPhone (even after reboot).

2,943 notes.

I also have this issue on iOS (iPhone 14, running 16.5.1), using Bear’s 2.0.5 (production version). I add the ‘1 note’ widget (any size), try to edit it, but cannot select another note. Rebooting my phone (as suggested above) did not fix the issue.

Yes. It’s still a problem for me. Hasn’t resolved with the production release. Unable to select the note in iPad or iPhone widgets.

Hi, do you happen to have a lot of notes in bear?

Hi Danilo,

Yep, 14k notes and counting.

Tom

1 Like

any updates on this one?

Hello,

we did some optimizations to the widgets’ note selection because we identified large collection of notes can saturate Bear’s widget extension memory. Are you sill experiencing this issue?

Hi Danilo,
I have a similar issue, I don’t know if it’s related to the one listed above.

When “Lock Bear with Face ID” setting is enabled, widgets can’t access notes database.

Is it the expected behavior?

For example OmniFocus widgets work even if the app is locked (this behavior makes sense to me).

There’s an additional bug:

If I enable ”lock with Face ID”, widget language switches to Chinese (both Bear and iOS language are set to Italian):

If I disable app locking:

Bear 2.0.14, iOS 17.0.3 (iPhone 13 Pro Max)

Hi Danilo, yes, the issue is still there. I checked before submitting my update question. :slight_smile:

Yes. This behavior was requested back in the day by some users concerned about privacy. The scenario is you hand your unlocked phone to someone and they access the widget library. In this scenario, they can read the note contained in Bear even if it’s locked. It’s not a common scenario but I have seen people handing phones to children to play/watch videos and I can understand the concern.

Oh thanks, this is a localization issue we’ll fix with the next update.

Thanks. I suspect we have to limit the selectable notes to the most recent 2/3 thousand to avoid crashes.
This will be added to the next update (2.0.16)

1 Like

Thanks for comprehensive explanation :pray: