Folding does not work correctly

Testing version:
2.0 (9780)

What were you doing:
I opened the “Welcome to the Bear 2 beta!” note and I tried to unfold/fold the heading with the name “Here’s a folded section you can play with ->”.

What feature did you use:
Folding keyboard shortcut cmd + '

What happened:
This text was appended after the heading: <!-- {"fold":true} -->

What did you expect to happen:
The section should fold/unfold.

I tried this and it worked correctly. I didn’t see the behavior you described. Where was your cursor when you entered the command?

The cursor can be everywhere on the line. I recorded a short video:

I had a note where the fold-true markup appeared at command-clicking a bullet point in a list. The bullet list was the last entry in a list that contained only first level. Command-clicking on another bullet folded the header above the list. Directly in the line after the last bullet point there was a tag. After I removed the tag the command-click on the same bullet point resulted in folding the header.

I added the tag agin but no chance more to see the fold-true markup.

(Apart from that: it is confusing that a click on a bullet list can fold a header. But that seems to be more a feature which I do not understand. I just have to add a sub bullet and the same click on the same bullet results in folding the bullet list. What is the benefit of such a behaviour?)

Thanks for reporting this problem. I also struggle to simulate this issue on the welcome note, any chance you have edited the note content? If this is the case, please send me your welcome note.

I didn’t edit the note. I just followed the text in it and I tried to unfold the panda picture. I’m not sure what more can I do to help you reproduce this issue.

I tried to attach the note exported as “*.bear” but it looks like it is not officially supported here!!! So I compressed it:

Welcome to the #Bear 2# beta! (3.3 MB)

1 Like

I’m experiencing the same bug in the welcome note on every header below the “Folding” header. I did edit the note slightly, one of the things I did was reorder the list in the “Footnotes” section with click-and-drag.

Attached is my welcome note, also compressed since .bear files aren’t allowed on this forum.
Welcome to the #Bear 2# beta! (3.3 MB)

Hello, can you please confirm you have the latest build (9803)? Click on Bear > Check for updates... download the latest build.

Confirmed, this bug is presenting itself on build 9803 for me.

Ok, I was finally able to simulate the issue.
Thanks a lot for (re) reporting this bug.

1 Like

@trix180 Hi! I just got the same bug, it appears to me that it is related to the divider block - it happens only when I try to fold the section while the courser is located right above the divider block and the block itself is empty

1 Like