Incosistent "- -" to "–" em dash behavior

Testing version:
Panda Version 1.0 (3146)

What were you doing:
I was editing a note. I was trying to write down a quote (not using quote markdown, but just with quotation marks), and then on the next line I wanted to attribute it to someone by typing “–”.

What feature did you use:
Panda note editor

What happened:
When I went to the next line after my quote and typed “--”, it turned into a line seperator and made the quote a header. (This feels so obtrusive and I don’t like it BUT I read the other posts saying that’s just how markdown works now so :man_shrugging:.

THEN, after the line seperator appeared, I pressed space and typed my quote attribution, like so: “-- quote attribution” (minus the quotes - i just put them there because otherwise the forum turns it into an em dash - ironically that’s what I was expecting!)

What did you expect to happen:
I was expecting panda to turn “-- quote attribution” automatically into “– quote attribution” (or “— quote attribution” ? em dashes and en dashes are confusing), but it left it as “--”.

This is inconsistent behavior because when I type my quote, press enter, then type “--”, then the line seperator/heading stuff appears, then I immediately type “quote attribution” without pressing space, in that case “--” DOES "turn into “–”!

(Again imagine all the above text without any actual quotation marks.)

That was confusing so here is a gif:


I wish “--” would turn into “–” even when there’s text above and I press space (case #2 in the gif), just like cases #3 and #4.

(I also with that the setext seperator thingy wouldn’t even kick in until I type 3 hyphens “---” but maybe then that’s violating markdown stuff?)

1 Like

I asked about this too a while ago. Apparently this is the way markdown is supposed to work.

Just FYI, two possible workarounds for this:

  1. You can easily type an en dash or em dash by holding ⌥ or ⇧⌥ respectively when pressing hyphen
  2. You could try explicitly adding this under “Text Replacements…” in System Settings → Keyboard (though I don’t know for sure whether that would take priority over Bear’s text handling)

I used to have en dash as a text replacement but it was rather confusing when used in Bear, like what the OP described. I think Bear’s handling takes priority. So I’ve gone back to using the ⌥ + - instead since that ensures the output is what I intend.