New note created from a wikilink is not editable, then editing is blocked for all notes

Testing version: Version 2.0 (10641)
Tested on Mac, but happening on iOS too

What were you doing:

  • Edited an existing note and added brackets around a word (a note with that title did not exist yet)
  • pressed into the wikilink to create a new note

What happened:

  • Cannot edit this page
  • Navigating to other notes and trying to edit them is not working either. All notes are no longer editable.
  • After force exiting and relaunching app, other notes are editable - but the new note no longer appears.

What did you expect to happen: New note should be editable (as well as other notes)

I’ve experienced something similar, but realized the new note I linked to was actually an oln note in Trash. Not seeing that, I tried to edit, but edit is locked on notaes in Trash, Tested other notes they were also locked, but finally realized that my note list was Trash.

Maybe that’s what happened?

Maybe Wiki-Links should be disabled for notes in Trash? It’s quite confusing…


Ah! true! It was in the trash when I tried to test it :slightly_smiling_face:
If I deleted it from the trash, the editing works when the note is recreated not in the trash.

This means the wikilinks should ignore notes in the trash and create one instead of linking to a trashed note.